Programmer avec le langage Linotte

Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
Programmer avec le langage Linotte

Besoin d'un conseil sur la programmation en Linotte ?

-30%
Le deal à ne pas rater :
WD Blue™ – Disque SSD Interne – SN550 – 1To
69.99 € 99.99 €
Voir le deal

2 participants

J'ai un soucis avec la méthode fonctionnelle ".désactiver"

avatar
LeBou
Junior Member


Messages : 28
Date d'inscription : 2015-01-28
Localisation : Lot 46

J'ai un soucis avec la méthode fonctionnelle ".désactiver" Empty J'ai un soucis avec la méthode fonctionnelle ".désactiver"

Message par LeBou Sat 5 Sep - 15:49

Sauf erreur de ma part, dans l'exemple suivant :[php]
Globale
fenêtre est un formulaire, hauteur vaut 170, largeur vaut 350
b1 est un bouton, x vaut 100, y vaut 100
Principale :
Début
Ajoute b1 dans fenêtre
Fais réagir b1 à "clic souris" pour affichage
tant que vrai, lis
temporise
ferme
affichage :
début
affiche "le bouton b1 fonctionne"
b1.désactiver(vrai)
reviens[/php]
La fonction désactiver ne fonctionne pas. (le bouton se grise mais il est toujours actif)
avatar
LeBou
Junior Member


Messages : 28
Date d'inscription : 2015-01-28
Localisation : Lot 46

J'ai un soucis avec la méthode fonctionnelle ".désactiver" Empty RE: J'ai un soucis avec la méthode fonctionnelle ".désactiver"

Message par LeBou Sun 6 Sep - 15:11

J'ai le même problème avec l'espèce "indicateur". L'instruction [indicateur.désactiver(vrai) ] ne semble pas fonctionner.
admincpc
admincpc
Site Admin


Messages : 1048
Date d'inscription : 2011-11-03

J'ai un soucis avec la méthode fonctionnelle ".désactiver" Empty RE: J'ai un soucis avec la méthode fonctionnelle ".désactiver"

Message par admincpc Mon 7 Sep - 9:28

je regarde et corrige le cas échéant ! merci pour les exemples.
admincpc
admincpc
Site Admin


Messages : 1048
Date d'inscription : 2011-11-03

J'ai un soucis avec la méthode fonctionnelle ".désactiver" Empty RE: J'ai un soucis avec la méthode fonctionnelle ".désactiver"

Message par admincpc Tue 8 Sep - 12:20

Oui, il y a bien un problème avec le Bouton.
ça sera corrigé dans la prochaine 2.5.1 qui doit sortir cette semaine.
(elle contient surtout des corrections liées à la programmation visuelle)

Pour l'espèce indicateur, c'est un peu plus long à corriger... je verrai ça plus tard !

Contenu sponsorisé


J'ai un soucis avec la méthode fonctionnelle ".désactiver" Empty Re: J'ai un soucis avec la méthode fonctionnelle ".désactiver"

Message par Contenu sponsorisé


    La date/heure actuelle est Sat 27 Nov - 6:52